IT Systems Engineering

Use hardware VSS writers in DPM 2012 R2:

I was trying to leverage our SAN hardware’s snapshot capabilities for backup and restore purposes. I noticed that DPM is able to use hardware VSS writers instead of using the regular VSS software provider. The advantage is that snapping is done by the hardware….meaning it is much faster!

Here is how I did it for our 3PAR 7400 SAN and our LeftHand P4000 SAN. The backup software I am using is SC DPM 2012 R2

Steps to be taken on all backup servers, all Hyper-V nodes in the HV cluster and all Hyper- Standalone nodes:

 

1. Install DOT NET 3 from “Add Roles and features” in Server Manager

2. Install CLI tools for 3PAR.

3. Install “Hardware VSS Provider” for 3PAR

4. Install LeftHand Application Aware Snapshot Manager (their VSS provider)

5. Make sure both VSS providers authenticates properly with both SANs

6. On an elevated cmd prompt run

vssadmin list providers

You should see the 3PAR Hardware VSS Provider listed (earlier it was not)

clip_image002

Steps to be taken on the backup server running DPM:

 

Follow instructions listed here:

http://technet.microsoft.com/en-us/library/ff634216.aspx

Note: On my DPM 2012 R2, we only had this file DatasourceGroupsSample.xml. I deleted it.

Upon running a backup again, I see snapshots getting created in both the SANs. Yahoo!

There is always something…

There is still one problem…the snapshots (even though they are on the SAN) get transferred over the regular TCP/IP network to the backup server’s local disk array. I want them to be transferred over Fiber Channel or iSCSI, depending upon the SAN’s connectivity. At this point, I am searching for an answer to this last piece of the puzzle.

The documentation of both hardware VSS writers I implemented say that it is do-able….but DPM is not doing it, right now. If I find the solution, I’ll post it here.

3 Comments

  • Mike

    Hi, In my environment I cannot see snapshots being done on the 3PAR, I Have followed your procedure… have you ever solved your problem os snapshots being transfered by TCP/IP?

    • Rajeev

      Unfortunately, even in my environment the SAN snapshots have stopped working. They stopped working after a SAN OS upgrade about an year back. I have not been able to get them working again after that. Tried upgrading the hardware VSS writer software also. HP tech support is not very helpful in getting this issue resolved.
      And no, I have not solved the problem of snapshots going over TCP/IP. I tried to mitigate that problem by buying 10GB switches and NICs.

Leave a Reply to Mike Cancel reply

Your email address will not be published. Required fields are marked *

Prove that you are a human *